בעית תיקון: השרת שלך פועל גרסת PHP אבל וורדפרס 5.1.6 3.2.1 5.2.4 דורש לפחות.

הודעה לכל אינה ידועה היטב כי כדי להתקין או לעשות שדרוגלקליק לגרסה חדשה של 3.2זה הכרחי כי להיות מותקן גרסה חדשה יותר של 5.2.4.

אם השרת הוא להתקין גרסה הישנה יותר של PHP 5.2.4, התקנת גרסה וורדפרס 3.2.1יופיע שגיאה / הודעה "השרת שלך פועל גרסת PHP וורדפרס 5.1.6 3.2.1 אבל דורש לפחות 5.2.4".
הבעיה יכולה להיפתר על ידי שדרוג פשוט מאוד PHP, אבל לפני שיעשה זאת יש לשקול כמה דברים. ראשית, לשדרג PHP אירוח מוחרג משיתוף. אז אתה יכול לעשות את השדרוג זקוק להרשאת גישה מנהלתית לשרת (שרת ייעודי או VPS). במקרה השני, לפני השדרוג חייב להיזהר למסמך וכי גרסה חדשה של PHP לא לתת אתרי שגיאות אחרים המתארחים בשרת.

עבור מערכת ההפעלה הנפוצה ביותר שרת אינטרנט (Agreart ו / WHM) יראה לכם כיצד לעשות שדרוג ל-PHP על CentOS 5.2.10.x 5 32 סיביות.

שדרג ל- PHP 5.1.x 5.2.x על 5 סיביות CentOS 32.x

1. בדוק אילו חבילות / מודולים מותקנים PHP (לשעבר. PHP-mcrypt) בנוסף מנות סטנדרטיות. אם בכלל, הם יימחקו או actuzlizate.

בדוק את החבילות המותקנות:

סל"ד -qa | grep php

old_php_version

2. להוסיף ארכיונים חדשים נדרש שדרוגגרסת PHP acquis.

ננו / etc / yum.repos.d / CentOS-Testing.repo

בקובץ החדש שנוצר (CentOS-Testing.repoהאם) להוסיף את השורות שלהלן (העתק / הדבק):

[C5-בדיקה]
name = 5 CentOS-בדיקה
baseurl = http: //dev.centos.org/centos/$releasever/testing/$basearch/
מופעל = 1
gpgcheck = 1
gpgkey = http: //dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X כדי לשמור את הקובץ CentOS-Testing.repo.

3. PHP עדכון באמצעות yum:

עדכון יאם

4. הפעל מחדש / httpd :

שירות httpd מחדש

אחרי שהגרסה מחדש httpd ולבדוק את החבילות המותקנות:

new_php_version

בדוק שגיאות מודולים / חבילות:

PHP-V

שדרג PHP / 32 הסיבית CentOS (i386).

בעית תיקון: השרת שלך פועל גרסת PHP אבל וורדפרס 5.1.6 3.2.1 5.2.4 דורש לפחות.

על הסופר

התגנבות LP

מייסד ועורך הגדרות התגנבותבתאריך 2006.
ניסיון במערכות הפעלת לינוקס (במיוחד CentOS), Mac OS X, Windows XP> Windows 10 וורדפרס (CMS).

השאירו תגובה

אתר זה משתמש Akismet כדי להפחית דואר זבל. למד כיצד הנתונים שלך מעובדים.